Reply
 
Thread Tools Display Modes
 
Old 05-27-2019, 08:47 PM   #1
Junior Member
 
Join Date: Mar 2014
Posts: 21
Cruise control stopped working

Hi all,
My cruise control stopped working the other day on a road trip from the SF Bay area down to Bakersfield.
I could find anything in the owners manual that might suggest what the problem is.
I have an 06 E350. Any suggestions would be appreciated.

Thanks in advance,
Eric
__________________

Eric06E350 is offline   Reply With Quote
Old 05-27-2019, 09:09 PM   #2
Senior Member
 
rallypanam's Avatar
 
Join Date: Feb 2013
Location: San Francisco/Nevada City
Posts: 3,638
Steering wheel buttons are known issues... and easily and cheaply fixed.
__________________

rallypanam is offline   Reply With Quote
Old 05-27-2019, 09:22 PM   #3
Senior Member
 
mikracer's Avatar
 
Join Date: Sep 2013
Location: San Luis Obispo, CA
Posts: 2,143
Could be the switch on the master cylinder. Easy part to swap or you can use a paperclip to jump it. If it works with the jumper, you know the switch has failed.
__________________
2005 E350 Chateau - V10 - Agile Offroad 4x4
2012 CTS-V Wagon - For the baby...
mikracer is offline   Reply With Quote
Old 05-28-2019, 07:40 AM   #4
JWA
Senior Member
 
Join Date: Jan 2011
Location: Reynoldsburg, Ohio
Posts: 2,165
Send a message via Yahoo to JWA
Quote:
Originally Posted by mikracer View Post
Could be the switch on the master cylinder. Easy part to swap or you can use a paperclip to jump it. If it works with the jumper, you know the switch has failed.
That is indeed one of the most common Ford VSC issue---I experienced it myself with a new-to-me 2003 E250 EB. If temporarily jumping the wiring harness contacts doesn't work it could be the mentioned steering wheel switches or a host of other issues including a burned out HMSL bulb.

After you've dug into the MC switch and that doesn't work please come back and we'll try helping you through this problem.
JWA is offline   Reply With Quote
Old 05-28-2019, 07:45 AM   #5
Senior Member
 
Join Date: Oct 2007
Posts: 483
Quote:
Originally Posted by mikracer View Post
Could be the switch on the master cylinder. Easy part to swap or you can use a paperclip to jump it. If it works with the jumper, you know the switch has failed.
The switch on the master cylinder fixed mine also. It was intermittent for a year at least. Sometimes when it rained it quit working. Fixed it 2 years ago and has worked perfectly since.
__________________
2008 Ford E-350 Quigley 4x4 V10 Gas - 144,000 miles
RB50, PH Top, Dual AGM Group 27 Deka, 2000 Tripplite Inv., No Propane or Water Systems
Van Weight 7,800 pounds, added one rear leaf to even it out, BFG AT KO LT265/70R17 E Tire press 50psi seems to run best at my van's weight.
Steve_382 is offline   Reply With Quote
Old 05-30-2019, 09:34 AM   #6
Senior Member
 
deserteagle56's Avatar
 
Join Date: Jan 2012
Location: Middle of Nevada
Posts: 105
This same problem is, literally, the ONLY problem I've had with my E350 since I bought it back in 2008. Cruise became intermittent and then quit altogether so I took it to the local Ford dealer who changed out a "Brake Switch" p/n 3L3Z9F924AB. That fixed the problem and it has not recurred.
__________________
Worshipper of Wild Country
2007 Quigley V-10 on 33s with 4.56 gears (Toyhauler)
deserteagle56 is offline   Reply With Quote
Old 05-30-2019, 07:21 PM   #7
Junior Member
 
Join Date: Mar 2014
Posts: 21
Thank you all for your input, I really appreciate it. I will look into and post my results.

Take care,
Eric
Eric06E350 is offline   Reply With Quote
Old 06-06-2019, 10:34 AM   #8
Junior Member
 
Join Date: Aug 2017
Posts: 7
My issue was also the switch on the Master Cylinder switch, take all of 5 minnutes to install.

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
sierraoneill is offline   Reply With Quote
Old 06-06-2019, 10:41 AM   #9
Junior Member
 
Join Date: Apr 2018
Posts: 23
For those that had this problem and fixed it. Were all of the buttons on your steering wheel not working? Including horn? My over drive button on the shifter works, but other than that, nothing on the steering column works.
DuggyFresh is online now   Reply With Quote
Old 06-06-2019, 10:46 AM   #10
Junior Member
 
Join Date: Aug 2017
Posts: 7
My only issue was the Cruise Control would stop working intermittently (like you tap the brakes and it turned off)..
__________________

sierraoneill is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Sportsmobile Registry

Moby

new2tx

White rhino

DIY4x4guy
Add your Sportsmobile
Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.