Reply
 
Thread Tools Display Modes
 
Old 07-03-2019, 02:26 PM   #1
Junior Member
 
Join Date: Aug 2017
Posts: 29
Dome and Door lights stopped working E350

On my last trip my dome and door lights stopped working. Everything else on that fused circuit still works (instrument cluster, and stereo), and it seems like the door switches must work as well since the stereo turns off when you open the door (like normal). Any ideas? Vehicle is a 2007 E350 V10

Thanks!
__________________

sierraoneill is offline   Reply With Quote
Old 07-03-2019, 05:27 PM   #2
Senior Member
 
oldbonesclimber's Avatar
 
Join Date: May 2007
Location: Los Osos, CA
Posts: 275
You may have pushed the button to turn off the light at the light fixture. I keep mine turned off except when I want it.
__________________

__________________
2007 RB50 6.0 PSD Walker Evans Streetlocks, 305X70X17 Terra Grapplers Custom Aluminess Roof Rack, ETC ETC
oldbonesclimber is offline   Reply With Quote
Old 07-03-2019, 05:40 PM   #3
Senior Member
 
Twoxentrix's Avatar
 
Join Date: Mar 2015
Location: Annapolis, Maryland
Posts: 1,150
Garage
Lost both dome lights at the same time a year ago. Truly no intention here of coming across insulting, but have you check the bulbs?
__________________
TwoXentrix
"AWOL"
Twoxentrix is offline   Reply With Quote
Old 07-04-2019, 01:28 AM   #4
Junior Member
 
Join Date: Aug 2017
Posts: 29
I have not checked the bulbs as it is several lights not working (LED's included).... All door lights (lights at the floor panels) will not light.....(passenger, driver, barn doors and rear doors)... so it;s a bit deeper than that..There is no button to turn off all lights including Dome lights on my van that I am aware of...... Dome lights are dead both under Driver and Passenger seats as well as in the back at the rear doors. Some Relay I might be missing???

I was on a parasitic draw search a few months ago which was solved, and in the process replaced both relays deep under the dash (Battery saver and some other... cant remember but same P/N )... This is pretty is an odd one since everything else on the circuit is still live (radio and Instrument panel). Fortunately its totally something I can do without and really care less about...but the OCD about it not working makes me crazy!!!
sierraoneill is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×