Reply
 
Thread Tools Display Modes
 
Old 06-21-2011, 11:09 AM   #1
Member
 
Join Date: Jun 2010
Posts: 47
P2614 6.0 Cam Shaft position sensor open? Bad Sensor?

My dealership is horrible and my closest mechanic is an hour long tow away

I had the ck engine light come on, then off then back and then I parked her. Now she cranks but won't start. Does anyone know if this sensor often goes bad? I had a engine wiring harness issue (frayed wire around a bolt) about 10k ago that I had repaired from a well trusted mechanic which was throwing the same code at the time. Any thoughts?

The parts cheap, but I thought I would get some feedback with from someone with experience? Thanks a ton!
__________________

khalilsc is offline   Reply With Quote
Old 06-21-2011, 03:47 PM   #2
Site Team
 
daveb's Avatar
 
Join Date: May 2007
Location: Turlock Ca
Posts: 9,806
Garage
Re: P2614 6.0 Cam Shaft position sensor open? Bad Sensor?

it is more of an issue with the 7.3 than the 6.0

more info here
viewtopic.php?f=39&t=5372
viewtopic.php?f=39&t=3692
viewtopic.php?f=8&t=3665
viewtopic.php?f=13&t=2871
viewtopic.php?f=13&t=2101
viewtopic.php?f=39&t=756
__________________
2006 Ford 6.0PSD EB-50/E-PH SMB 4X4 Rock Crawler Trailer

Sportsmobile 4X4 Adventures..........On and off road adventures
daveb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Sportsmobile Registry

Rosy

Isever

Agnes

ranchero
Add your Sportsmobile
Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.