Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Display Modes
 
Old 02-19-2016, 11:13 AM   #1
Senior Member
 
Join Date: Aug 2011
Location: Wyoming
Posts: 321
Mass Air Flow Sensor?

I did a search and didn't fine much on this topic. So, As some of you know I've been chasing down my sudden loss in about 3MPG, it recently occurred to me that I had cleaned the air filter before the trip I noticed the decrease, could this be a factor? It's a K&N, did I use too much oil and coat the MAF? If so, how do I clean it?

Any help on this is much appreciated.

C.
__________________

c7train is offline   Reply With Quote
Old 02-19-2016, 11:22 AM   #2
Member
 
Join Date: Sep 2013
Location: Cotati, CA
Posts: 39
I would think that if the MAF sensor had an issue it would throw an error code and your check engine light would come on. You need to clean it with a special cleaner.
CRC/Mass air flow sensor cleaner 05110 - Read 5 Reviews on CRC #05110
This is what I have used. My parents car just had this problem. Had P0170 and P0173 error codes (Fuel Trim Malfunctions bank 1 and 2). I hear cleaning the sensor works a lot of the time but in my case I had to replace the sensor.
__________________

__________________
1998 E350 4x4 7.3l Club Wagon Chateau with SMB top
trquinn is offline   Reply With Quote
Old 02-19-2016, 11:46 AM   #3
Senior Member
 
JackTuppVan's Avatar
 
Join Date: Nov 2014
Location: TN
Posts: 299
How to clean the Ford MAF sensor Part 1 -How to Clean the Ford MAF Sensor (Ford 4.2L, 4.6L, 5.4L)
__________________
2007 E250 Super Duty cargo
1988 Toyota Van 4x4 5-spd
JackTuppVan is offline   Reply With Quote
Old 02-19-2016, 12:19 PM   #4
Senior Member
 
carringb's Avatar
 
Join Date: Jan 2009
Location: Corvallis, OR
Posts: 5,085
Quote:
Originally Posted by trquinn View Post
I would think that if the MAF sensor had an issue it would throw an error code and your check engine light would come on.
Mine has never thrown a code when over-oiled. It simply leans out the mixture to the point in can ping under high load / low RPM, or pull timing. I carry a an of cleaner with me now. My AFE filter hasn't been as bad on contaminating the sensor as my K&N was, probably since since the AFE is about 4x the size it doesn't pull as much oil through.
__________________
2000 E450 dually V10 wagon
carringb is offline   Reply With Quote
Old 02-22-2016, 07:07 AM   #5
Senior Member
 
Join Date: Aug 2011
Location: Wyoming
Posts: 321
The check engine light is not on at this point. I'll give a look to the links provided (thanks for those!) and see what I can find. SMBF to the rescue!
c7train is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×