Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Display Modes
 
Old 01-07-2018, 12:03 PM   #11
Senior Member
 
TomsBeast's Avatar
 
Join Date: Nov 2012
Location: Brentwood, CA
Posts: 984
I tracked it down to a t-case failure, pulled it out and opened it up on the bench yesterday.

http://www.sportsmobileforum.com/for...tml#post219147

Here's a link where you can read all the dirty details w/pictures of the carnage.

Borg Warner 1356 failure - PowerStrokeNation : Ford Powerstroke Diesel Forum
__________________

__________________
1995 E350 7.3 Diesel, 4x4 high roof camper, UJOR 4" lift
TomsBeast is offline   Reply With Quote
Old 01-07-2018, 03:44 PM   #12
Senior Member
 
Join Date: May 2015
Posts: 138
Read your link...I would suggest getting a complete used TC rather than just repairing yours. 400+ miles on 6oz of oil will cause all kinds of wear that might not show up until further down the road.
__________________

Poptopper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×