Reply
 
Thread Tools Display Modes
 
Old 09-05-2013, 10:45 AM   #11
Senior Member
 
BrianW's Avatar
 
Join Date: Apr 2012
Location: Philadelphia, PA
Posts: 3,085
Re: Ford E250 SMB, Turn signals and hazards are out.

Just ordered the Echlin part from Napa: ECH DL6170 for my 1998 E250. Hopefully this should solve the problem.

http://www.napaonline.com/Catalog/Catal ... 0372691954

They also have a cheaper version in the "Mileage Plus Electrical" line, but it only has a 1-year warranty vs. the 3 year for the Echlin. The Echlin is about $15 more ($57 vs. $71), but based on CarringB's suggestion and the additional warranty term I went with the higher-priced one.
__________________

BrianW is offline   Reply With Quote
Old 09-06-2013, 02:19 PM   #12
Senior Member
 
BrianW's Avatar
 
Join Date: Apr 2012
Location: Philadelphia, PA
Posts: 3,085
Re: Ford E250 SMB, Turn signals and hazards are out.

I got the Echlin turn signal combo switch this afternoon and installed it a few minutes ago. A very easy install, and solved all my turn signal/hazard light issues.

I posted it earlier, but here's the link again to a photo tutorial (not mine) on the Ford Truck forum:

http://www.ford-trucks.com/forums/11535 ... added.html
__________________

BrianW is offline   Reply With Quote
Old 09-06-2013, 02:39 PM   #13
Senior Member
 
BrianBlair's Avatar
 
Join Date: Aug 2013
Location: Silverado, CA
Posts: 442
Re: Ford E250 SMB, Turn signals and hazards are out.

Awesome, I'm picking mine up at Napa tomorrow. Thanks for the info.
BrianBlair is offline   Reply With Quote
Old 09-07-2013, 09:25 PM   #14
Senior Member
 
jage's Avatar
 
Join Date: Apr 2007
Location: Franktown, CO
Posts: 7,597
Re: Ford E250 SMB, Turn signals and hazards are out.

On the fuses, you might go ahead and pull them and switch them out- sometimes all looks good but it's not.
__________________
and then
everything changed
jage is offline   Reply With Quote
Old 08-15-2017, 02:19 PM   #15
Junior Member
 
Join Date: Aug 2017
Posts: 6
Quote:
Originally Posted by carringb View Post
The "multi-function switch" (aka turn signal stalk) is pretty notorious for going out. This is one part where you're better off with a Napa Echlin replacement instead of a Ford replacement. Any fleet with older Fords will probably have boxes of bad switches. Unfortunately the diagnostics procedure for testing it is "replace with known good part".

BTW - are you sure you checked the right fuses? The ones under the hood only do trailer lights. The ones under the dash do the van lights.
I also am have a similar problem with mine. It is a 1997 E-350 Econoline. Flasher is working and I checked all fuses and relays under hood as well as under dash. One brake lamp was not working so I bought new turn lamps and brake lights thinking that was the problem but only one brake lamp was blown but brake lamps are working now. Still no turn signals. Tested continuity at flasher relay and when i push the turn switch or hazard switch i have power. Could that still be the problem with the multi-function switch or loose connections behind dash?
BlueWolf291 is offline   Reply With Quote
Old 08-15-2017, 04:18 PM   #16
Senior Member
 
BrianW's Avatar
 
Join Date: Apr 2012
Location: Philadelphia, PA
Posts: 3,085
Ford E250 SMB, Turn signals and hazards are out.

Same symptoms on my 1998 E250 a few years ago and it was the multi function switch. Pretty easy to replace. I used the NAPA Echlin one, but one thing I don't like is that it sits pretty close to the steering wheel compared with the stock one, and sometimes I hit it into high-beam mode by accident.
BrianW is offline   Reply With Quote
Old 08-17-2017, 08:43 AM   #17
Junior Member
 
Join Date: Aug 2017
Posts: 6
Well it's odd now the blinkers are working but brake lights are not working? I feel very confused now. Wouldn't those be on separate lines? I don't think the brakes and blinkers would be connected. So is it possible I have loose connections under the dash somewhere? I would love for it to be the multi switch and I could deal with bumping it into high beam by accident but I don't think it is that since they are working this morning with the brake lights not. I don't know what is going on.
BlueWolf291 is offline   Reply With Quote
Old 08-17-2017, 10:35 AM   #18
Senior Member
 
TomsBeast's Avatar
 
Join Date: Nov 2012
Location: Brentwood, CA
Posts: 856
Check your grounds, all of them
__________________

__________________
1995 E350 7.3 Diesel, 4x4 high roof camper, UJOR 4" lift
TomsBeast is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.