Reply
 
Thread Tools Display Modes
 
Old 10-25-2011, 03:23 PM   #1
Senior Member
 
SierraHawk's Avatar
 
Join Date: Jun 2009
Posts: 196
Problem with engine misfire at mid throttle and under load

I had posted a note about our 2003 5.4L engine misfiring at mid throttle and under load earlier. I wanted to do a follow up but somehow it has dissappeared.

FYI I had originally thought that this was a fuel side problem (ie, water in gas, clogged jets, etc)but could not find a remedy . Local shop in Bangor did a code check that basicly said we had to take it into Ford for the diagnostics. This was not a cheap fix ($470). They found that two of the sparkplugs and coils needed to be replaced. So far we have driven 4000 miles and have not had any similar problems emerge.
__________________

SierraHawk is offline   Reply With Quote
Old 12-15-2011, 09:25 PM   #2
Junior Member
 
Join Date: Oct 2009
Location: Washington
Posts: 9
Re: Problem with engine misfire at mid throttle and under lo

You have a one of the coils on your spark plugs going out. I started replacing mine at 60000 and had one go out for the next three years. Tired of the cost of each one per year, finally replaced them all. Spark plugs good coils bad, dealer said there is too much heat build up in the van design compaired to pickups. Whatever.
Ateam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.