Reply
 
Thread Tools Display Modes
 
Old 04-13-2013, 10:52 AM   #1
Member
 
Join Date: Apr 2010
Posts: 34
Bug deflector turbulence

Hi,

I have a 2007 SMB RB and installed a Ford OEM hood bug deflector. I just noticed at freeway speeds a great deal of turbulence and hood shake.

I've checked the hood security and the installaion of the deflector and have started to think the deflector is the problem, not the hood itself. Anyone had this problem before?

Next step is to remove the delfector and test drive, but its a rainy Saturday in the PNW...
__________________

dar636 is offline   Reply With Quote
Old 04-13-2013, 11:01 AM   #2
Site Team
 
BroncoHauler's Avatar
 
Join Date: May 2007
Location: Southern New Mexico
Posts: 9,111
Re: Bug deflector turbulence

Are you talking about one of those tinted plastic deflectors that goes at the leading edge of the hood? If installed properly, I can't imagine that plastic causing much turbulence.

FWIW, I don't believe they are Ford OEM, though they may be Ford dealership sold and installed.


Herb
__________________

__________________
SMB-less as of 02/04/2012. Our savings account is richer, but our adventures are poorer.
BroncoHauler is offline   Reply With Quote
Old 04-13-2013, 05:10 PM   #3
Senior Member
 
Join Date: Jun 2008
Location: Salinas, CA
Posts: 147
Re: Bug deflector turbulence

I had one on my 2008 and never thought it actually worked. I got a cracked windshield almost immediately after I put it on, but left it on. I eventually took it off for cosmetic reasons. After about 5,000 miles without it I just got a nice star in my new Safelite windshield ... such is life ... it's a big target. I like the looks of the 2008 grill better without the bug deflector ... which, of course, IMHO, doesn't really work. That said, it would stop paint chips right on the front edge of the hood.

Never noticed any turbulence problems. I did notice my hood latched a little loose and that was an easy fix by moving the latch on the van body down.
salivan is offline   Reply With Quote
Old 04-13-2013, 10:52 PM   #4
Member
 
Join Date: Apr 2010
Posts: 34
Re: Bug deflector turbulence

Hi Broncohauler-

Yes, I am talking about the tinted deflectors - it could be that it isn't OEM, I dont recall the box it came in when I pciked it up from the dealer. I've installed a few before and this one had instructions, etc...no problem to locate and install.


Last road trip at 65 MPH or so, with a stiff headwind is when I noticed a buffeting and enough turbulence to cause the wipers to shake around in the stowed position, which made me lean forward and look over the hood. Thats when I noticed the aft edge of the hood shaking fairly violently. I pulled over and checked that it was latched and then checked for a loose rear bumber stop or some reason for the movement. There isnt really a stop or rest for the back edge of the hood.

Anyhow - I'll pull it off and go for a ride tomorrow. Just thought I'd ask around first.
dar636 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Sportsmobile Registry

Lola

Eddie Haskell

Clyde

ormtnbiker
Add your Sportsmobile
Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×