Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Display Modes
 
Old 08-30-2010, 06:06 PM   #1
Senior Member
 
Railvan's Avatar
 
Join Date: Jun 2007
Posts: 249
Thetford electric PortaPotty doesn't pump

My PortaPotty electric pump has quit working. The electric pump does not pump fresh water when the button is pushed. I put new batteries in it and checked the voltage from the battery pack and it is fine.

The Thetford 800 phone number is useless. It plays a recording the repeats without ever giving options to speak to anyone.

The website lists service centers and the info for the one in Bellingham where I live is incorrect and the company listed does not service Thetford products.

The website shows a parts breakdown, and the whole pump assembly is one unit, part #25074.

Anyone know of a good online place to get parts?

I recall hearing that the manual pump is a direct replacement. Anyone know which pump will drop in?

Thanks,

Brian Rutherford
__________________

__________________
https://www.pbase.com/railvan
2006 Ford RB, 6.0 diesel, SMB 4x4, RB50
Railvan is offline   Reply With Quote
Old 08-30-2010, 08:08 PM   #2
Senior Member
 
charlie56's Avatar
 
Join Date: Sep 2007
Location: santa rosa ca
Posts: 994
Thetford electric PortaPotty doesn't pump

Try badgertrek.com
Look under appliances



Sent from my iPhone using Tapatalk
__________________

__________________
... Charlie
EV-2 build is now complete, (yeah right).
KZ6T
charlie56 is offline   Reply With Quote
Old 08-31-2010, 12:02 PM   #3
Senior Member
 
yvrr's Avatar
 
Join Date: Oct 2007
Location: Newark, CA
Posts: 795
Re: Thetford electric PortaPotty doesn't pump

We broke the lid on our manual Porta Potti several years ago and were able to purchase a replacement. When we broke it again (stepping on it to get up to the penthouse*), we discovered that Sears had the entire units on sale cheaper than the cost of the replacement lids. You might check out a new unit, especially now that there might be "end of season" sales.

*The solution was to put non-skid tape on the edge of the seat so that we don't accidentally step on the weaker center of the seat...
__________________
Jack
'01 Ford EB50p Quigley 4WD
yvrr is offline   Reply With Quote
Old 08-31-2010, 04:13 PM   #4
Senior Member
 
John and Dana's Avatar
 
Join Date: Feb 2008
Location: Normandy Park, WA
Posts: 364
Re: Thetford electric PortaPotty doesn't pump

If Sears sells it there is a very good chance they have parts available for it on their website.

John
__________________
'08 SMB 4X4 6.0PSD EB 50 (96K)
John and Dana is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Sportsmobile Registry

Cool-Airo

mikewithered

Beni

hildems
Add your Sportsmobile
Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
×