Reply
 
Thread Tools Display Modes
 
Old 05-17-2013, 10:57 AM   #1
Senior Member
 
winvest's Avatar
 
Join Date: Mar 2008
Location: Southwestern Colorado
Posts: 106
6.0 PSD turbo issues?

I'm hearing a new sound from my 6.0 PSD when it downshifts, or I step on the gas to get to highway speed. It sounds like a loud rushing noise coming from the passenger side of the doghouse. Am I in for the dreaded turbo failure on my 6.0 PSD? I've also noticed a loss of power when this occurs. In my forum search about this problem, I saw mention of a high pressure line failure. Could this be it? Any help would be greatly appreciated.
__________________

__________________
'07 E350 4x4, voyager top, custom interior, prorock 60, arb front & back, aluminess front & back, hella lights, extreme air, braun wheelchair lift.

"Two roads diverged in a wood, and I took the one less traveled by. And that has made all the difference." - Robert Frost
winvest is offline   Reply With Quote
Old 05-17-2013, 11:30 AM   #2
Senior Member
 
carringb's Avatar
 
Join Date: Jan 2009
Location: Corvallis, OR
Posts: 4,219
Re: 6.0 PSD turbo issues?

Check all the flex coupling going to/from the intercooler. They blow off sometimes.
__________________

__________________
2000 E350 extended wagon dually
V10 w/ Banks Powerpack, Diablo Predator
Buckstop Outback bumper/grill guard
Reunel rear bumper
carringb is online now   Reply With Quote
Old 05-17-2013, 11:57 AM   #3
Senior Member
 
Join Date: Apr 2007
Location: Fruita, Colorado
Posts: 1,173
Re: 6.0 PSD turbo issues?

I can almost guarantee you that you have a loose or blown CAC hose. Large blue hoses. Usually an easy fix.
__________________
Desert Solitaire
2003 7.3L EB 4x4
Denver Fleet 4x4 conversion
saline is offline   Reply With Quote
Old 05-17-2013, 12:06 PM   #4
Site Team
 
daveb's Avatar
 
Join Date: May 2007
Location: Turlock Ca
Posts: 9,806
Garage
Re: 6.0 PSD turbo issues?

Same thing happened to me years back on my 06. Think Ford had an upgrade clamp or hose.
__________________
2006 Ford 6.0PSD EB-50/E-PH SMB 4X4 Rock Crawler Trailer

Sportsmobile 4X4 Adventures..........On and off road adventures
daveb is offline   Reply With Quote
Old 05-20-2013, 09:41 AM   #5
Senior Member
 
winvest's Avatar
 
Join Date: Mar 2008
Location: Southwestern Colorado
Posts: 106
Re: 6.0 PSD turbo issues?

Thanks everyone for the help. I will check it out and see if that is the issue.
__________________
'07 E350 4x4, voyager top, custom interior, prorock 60, arb front & back, aluminess front & back, hella lights, extreme air, braun wheelchair lift.

"Two roads diverged in a wood, and I took the one less traveled by. And that has made all the difference." - Robert Frost
winvest is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Sportsmobile SIP or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.